MOUNTAIN LION 10.8 WORKING on SHUTTLE XPC SH67H3/7 Motherboard V1

These are instructions from one of our blog readers gatd, thanks man!

First update your BIOs to the latest version

In windows update your USB 3 Firmware and Drivers to the latest version

Download MultiBeast 4.6.1 and 5.0.2 and ShowAllFiles from www.tonymacx86.com and put on another USB stick

Download UniBeast Mountain Lion 1.5.3

Run and select your ML image (it takes a while so be patient)

Copy onto your USB stick

In BIOS set your USB stick as the First Drive

Format your HD as 1 partition GUID (select in Options)

Install ML ( I used a wired Mac keyboard and mouse in the rear  top USB 2 port)

Keep USB Stick in

On reboot Select Your HD (right arrow at screen after bios)

Fill out your details

Start Using ML

At this point I filled out all my mac details for iTunes, iCloud, FaceTime and Messages.

Then run Multibeast 5.0.2 ( Hold the ctrl Key on your Keyboard to open) and select the following:

 Drivers & Bootloaders / Drivers / Audio select  = Realtek ALC8xx /Without DSDT / ALC888 / V100302 Current ( my board has ALC888)

Miscellaneous / = FakeSMC and NullCPUPowerManagement and USB 3.0 -3rd Party

Network / = Lnx2Mac’s RealtekRTL81xx

Customizations /System Definitions = Mac mini (I am using a i3 with HD3000 built in Graphics)

/Themes  = tonymacx86

Bootloaders / = Chimera v1.11 r1394

Run “showallfiles” and go to the Extra folder on your HD and open the org.chameleon.Boot.plist (it is invisible)

Replace contents with:

<?xml version=”1.0″ encoding=”UTF-8″?>

<!DOCTYPE plist PUBLIC “-//Apple//DTD PLIST 1.0//EN” “http://www.apple.com/DTDs/PropertyList-1.0.dtd”&gt;

<plist version=”1.0″>

<dict>

<key>EthernetBuiltIn</key>

<string>Yes</string>

<key>GraphicsEnabler</key>

<string>Yes</string>

<key>Kernel</key>

<string>mach_kernel</string>

<key>Kernel Flags</key>

<string>npci=0x3000 darkwake=0</string>

<key>Legacy Logo</key>

<string>Yes</string>

<key>Graphics Mode</key>

<string>1920x1080x32</string>

<key>Timeout</key>

<string>2</string>

</dict>

</plist>

SAVE

(the 1920x1080x32 part is for my TVs resolution and the Graphics enabler is for the built in graphics HD3000)

Open MultiBeast 4.6.1 ( Hold the ctrl Key on your Keyboard to open) and select System Utilities and continue then Install .

REBOOT

For bluetooth I am using a Belkin mini USB dongle F8T016NG and everything works great, including wake from sleep.

hope this helps someone

Advertisements

60 Responses to MOUNTAIN LION 10.8 WORKING on SHUTTLE XPC SH67H3/7 Motherboard V1

  1. gatd says:

    I have update to yosemite and works great even got audio over HDMI working

  2. Serion says:

    I install ML following this guide. I had everything working except for message, app store and iTunes. I followed a guide to get it working, but after that my resolution went back to 800×600 and graphic acceleration was no longer enabled. I checked org.chameleon.Boot.plist and everything looked correct. As a last ditch effort I ran multibeast 5.0.2 and installed the bootloader and system def again. Then when I tried to reboot I got to the screen where I chose to boot into OSX and the system resets.

    Should I just start everything over from scratch or can you recommend on a way to recover my system? This is my first Hackintosh system and I know very little about OS X. Thank you in advance!

    • cinlortech says:

      It would probably be faster and less hassle if you start from scratch. I had to do that several times to get most things working. Just don’t re-do what tanked it each time.

      I found another linux OS that emulates Mac OSX that I’m playing with now. Will be more compatible with the Shuttles.

      • Serion says:

        That’s what I was thinking, but wanted to ask first. Do you have a recommended way of getting message, app store and iTunes working? (That’s the fix that caused my graphic issues)

        Also after I get everything perfect (if that ever happens ha!), what’s the best way of backing it all up so that if I screw something up, I can just fall back on it?

      • cinlortech says:

        I never had issues with those apps before, they just worked after install.
        Mac has a built-in backup called “Time Machine” you can use for the backup.
        My major issues were the Asmedia USB 3.0 and native sound, I never got them
        working right on the H3 V1.

      • Serion says:

        I took your advice and reinstalled everything from scratch. I installed everything with a DVI connected monitor. The fix I used for iMessage was Chimera 2.1.1. (That includes the fix) I also used the latest Multibeast 5.3.1. I got my wireless USB adapter working too! (I did a backup this time too!) I editedorg.chameleon.Boot.plist for my res to be 1280x720x32 since I wanted to connect this to my TV as a HTPC.

        I move the computer over to the TV and book it up. The white screen with the Apple logo appears and the wheel spins for a few that stops. But I noticed the HD still spinning. I accidentally hit the keyboard and heard a noise so I then realized the desktop must be up but not showing. I hooked up the DVI monitor (while leaving the HDMI connected) and there’s the desktop on the monitor! I go to display and chose scaled and select 1024×768 (it was currently at 1280×960 which my TV doesn’t support (it’s 720p) After I did that I had a mirrored display on my TV. I pull out the DVI monitor cable and the TV goes blank! I plug the DVI back it and the TV comes on. What the heck is going on??? Any ideas on what I can try?

        Also sound…. I have it plugged in to digital output. it’s working if I play a MOV file. If I play an MP3 it just give static. Here’s another odd thing. If I go into sound and switch from digital to line in and back to digital it clears up and I hear the music. If I open another app that uses sound I get the same thing and the same thing fixes it. Any ideas on that one?

      • cinlortech says:

        Serion,

        Regarding the graphics, are you using the integrated or a graphics card?

        Regarding the sound, which driver did you use?

  3. Jix says:

    Hi,
    I have the v1 motherboard with last bios.
    My graphic card is a Nvidia GTX 560, and the processor is Core i7-2600 @ 3.4 GHz
    I have tried to install ML from an USB key, and I’m stuck at the boot screen, u can see it here : http://lantheaume.fr/shuttle/IMG_0062.JPG
    Can you help me ? I’m a newbie @ hackintosh
    Thx

    • cinlortech says:

      Hey Jix – Sorry for the late reply. Can you tell me exactly what steps you have done to get to this point.

      • jouix says:

        Hi,
        Sorry for late reply too, I was on holidays 🙂
        I have make a bootable USB disk with ML on it, my computer has started then it has showed the picture in my post, that’s all.

        Can you tell me how to activate the verbose mode (+v) ? I saw a +x mode too .. ?

        Thx

      • cinlortech says:

        Are you using UniBeast for the bootable USB drive? Do you have the ML installed in the “Applications” folder on the USB drive?
        To use verbose mode -v or safe mode -x, on the Chimera boot screen, I
        believe you hit the space bar for the command line. It’s been awhile since I last installed ML, so bare with me.

      • jouix says:

        I didn’t do that, that’s why …
        I’ll try it as soon as possible
        Thx

      • jouix says:

        I cannot install it, because it says :
        “UniBeast only supports English language systems.”
        Then it says : “Installation failed”
        My system is in french on my Macbook Pro, that’s probably why ..
        Any idea ? I cannot convert ML in english, it’s my working computer
        Thx

      • cinlortech says:

        I don’t think UniBeast comes in different languages. Only thing I can suggest, is buy a copy of ML in English from Apples website.

      • jix says:

        Don’t you think OSX should be in english, and not the ML copy on the Apple website ?

      • cinlortech says:

        Didn’t you say your ML is in French?? Maybe, I misunderstood…

      • jouix says:

        Yes it is 😦

      • jouix says:

        Is it possible to someone to make an ISO of the USB key, and upload it somewhere, like Dropbox or something else ?
        I’m stuck with Windows, and I’m crying every day .. 🙂
        Thank you

      • jouix says:

        Hi,
        For your information, you can change the language of ML in settings, and that’s all ..
        So my USB key is done, i will try to make my hackintosh this week-end 🙂

    • jouix says:

      Hi,
      I’ve made the USB key yesterday, that’s OK.

      I’ve booted with verbose mode ON, then the boot has stopped with this message : «Still waiting for root device»
      After googling, I’ve find I need to active AHCI Mode in bios, which is already active :
      In Bios, in Advanced / SATA Configuration, SATA Mode is in AHCI Mode.
      There is no other option in BIOS like enable SMART or Native Mode for ATA/IDE, like some people said (when googling)

      My shuttle is the SH67H7 with v1 rev for motherboard, and my BIOS is apparently the lastest (v1.16), as you can see here :
      http://global.shuttle.com/products/productsDownload?productId=1549

      Here is a screenshot with some errors, maybe it could help ?

      Any idea .. ? I’m stuck here

      Thx

      Jix

      • cinlortech says:

        Hey Jouix,

        It usually means it can’t find the USB drive to boot from it. Try the USB in different ports, preferably USB 2.0.
        You could try and remake the USB with UniBeast or try another flash drive. Also make sure the HDD you are installing on is on the 1st sata port.

      • jouix says:

        This is better with USB2 and SATA port 1, I don’t have the same error message.
        Now it continues to load, and after some time the screen goes black and the computer doesn’t respond anymore.
        Then I tried this commands and i could have installed OS X :
        -x -v PCIRootUID=0 npci=0x2000
        Now, when I boot on the hard drive, I have the message to “Reboot and Selcte proper Boot device”.
        An idea ?
        Thx

      • cinlortech says:

        Have you gotten to the point to install multibeast yet? If you haven’t, you still need to boot
        from the USB drive to complete the installation.
        Are you using the integrated graphics or a discrete graphics card? It would be better in install
        with the integrated graphics and add graphics card later.
        You might also try the command: GraphicsEnabler=No

      • jouix says:

        Almost there !!
        I put this -x -v PCIRootUID=0 npci=0×2000 GraphicsEnabler=Yes (I don’t have integrated video card) and it works.
        I’m under OS X, I’ve installed MultiBeast, last version (first part), and ShowAllFiles.
        I cannot find org.chameleon.Boot.plist in the Extra folder, any idea ?

      • cinlortech says:

        Do you see anything in the Extra folder?

      • jouix says:

        I tried to reboot without the USB key, it didn’t works (well I knew it but .. :o)
        I have rebooted with the USB key, so I am in OSX now.
        When I go in the Extra folder, there is 2 files (smbios.plist and .DS_Store) and 2 folders (Themes and modules), that’s all.

      • cinlortech says:

        Did you install Chimera from MultiBeast?
        And you ran ShowAllFiles?

      • jouix says:

        Yes I did it, first with the 1,11,1 r1394 version, and then with 2,0,1 r2109 version.
        I used the last Multibeast version (v5,3,1) from tonymacx86,com

      • jouix says:

        And I use ShowAllFIles (I can see .DS_Store)

      • cinlortech says:

        If Chimera is installed properly, you should be able to boot from the
        hard drive now. What does it do when you boot from the hard drive?

      • cinlortech says:

        Try copying the boot.plist file from the USB drive to the Extra folder on your hard drive.

      • jouix says:

        When I try to boot from HD, here are the messages :
        boot0: GPT
        boot0: test
        boot0: test
        boot0: GPT
        boot0: test
        boot0: test
        boot0: error
        and it stays like this

        I think I have to modify startup like I have to do to boot OSX using thx USB key (PCIRootUID=0 npci=0×2000 GraphicsEnabler=Yes )

      • jouix says:

        I ll try again now, but the file is not visible (is it important ?)

      • cinlortech says:

        You mean not visible on the hard drive? It is if you want to modify it. Before you reboot, put the file on your desktop and edit it. Make sure it have all the changes you made for booting from the USB. Then put it in the Extra folder and reboot.

      • jouix says:

        Sorry, my mistake.
        The file is visible, not in invible mode, is it a problem ?
        Other problems than boot :
        – it looks like laggy when i move a window, like graphic driver not installed properly (resolution is ok, my GC is a GTX560 not TI)
        – no sound : everything is grey in Parameters / Sound / Sounds effect (no sound going out from jack)
        Trying to reboot now ! 🙂

      • jouix says:

        It doesn’t want to boot … grrr
        Here is my org.chameleon.Boot.plist :

        EthernetBuiltIn
        Yes
        GraphicsEnabler
        Yes
        Kernel
        mach_kernel
        Kernel Flags
        PCIRootUID=0 npci=0×3000 darkwake=0
        Legacy Logo
        Yes
        Timeout
        2

        I said I have no sound, but it is not really true .. I ve installed Spotify and I can here a very little sound going out of my Internet Box, probably with Airplay .. but nothing from the speakers with the jack

      • jouix says:

        I copy paste the org.chameleon.Boot.plist inside but everything is not present ..
        so here is a link to download it :
        https://dl.dropboxusercontent.com/u/22163499/org.chameleon.Boot.plist
        like I said, this file is visible, not like a .fileinwhoisinvisiblebecauseofthedot, hope this is not th eproblem for non-booting 🙂

      • cinlortech says:

        Are you still getting the Boot0 error?
        Try changing the PCIRootUID=1

        I believe the npci=0x3000 is for integrated grapics, which you don’t have.
        I’m not sure what the darkwake=0 does.

        I have a post on how to fix a Boot0 error in the blog, you might want
        to look at that also. The post title is “Shuttle XH61 Lion”.

      • jouix says:

        The Boot0 error is solved, with help of this page : http://www.tonymacx86.com/25-boot0-error-official-guide.html
        But now, OS X is not starting, the loading page is .. loading 🙂
        Changes in the org.chameleon.Boot.plist doesn’t seem to do anything ..
        Is the only way to modify settings in startup is with this file ?
        Because if I do it with USB key, system start ..

      • cinlortech says:

        Glad you got the Boot0 error solved.

        Do you know what version of Chimera is on the USB drive?

        You said you upgraded the Chimera, I guess in MultiBeast or was it
        a separate upgrade? I’m not totally sure why it’s not booting from
        the hard drive now. Also, when you edit the boot.plist, you are saving
        the changes, right? Have you tried booting from the hard drive in verbose
        mode?

      • jouix says:

        I don’t know the version of Chimera on the USB Key, but I think I’ve did it with Multibeast 5.3.1.
        I tried the upgrade of Chimera with Multibeast (same 5.3.1).
        Here is a pic of the HDD boot with verbose mode :

        I don’t know what to do next …

      • jouix says:

        I just tried to put -x -v PCIRootUID=0 npci=0×2000 GraphicsEnabler=Yes without USB key, only with the hard drive, and it works .. I’m in OSX.
        Any idea to make it permanent ? It dosen’t seem to work with the plist file ..

      • cinlortech says:

        The only way I know of, is with the plist file.
        You changed the npci= from 0x3000 to 0x2000. Have a look at the plist file you uploaded.
        Are you editing the plist file from the Extra folder on the hard drive?
        Maybe edit the plist file somewhere else, delete the one that’s in there and re-copy
        after you make the changes.

        Is the sound working now? I know the sound has been an issue in the past with the SH67H3/7.

      • jouix says:

        I’ll try again next week-end, thx for the help 🙂

  4. Everett says:

    Do I need to purchase a separate Video Card for the Shuttle SH67H3 V1?

  5. Everett says:

    I will try to install Mac OS X 10.8.2 again in the near future. Hear are the errors that I had from the last try:

    2013-01-18 09:23:29 -0500 kernel[0]: Can’t load kext com.apple.driver.AppleSMCPDRC – failed to resolve library dependencies.
    2013-01-18 09:23:29 -0500 kernel[0]: Kext com.apple.driver.AppleSMCPDRC failed to load (0xdc00800e). 2013-01-18 09:23:29 -0500 com.apple.launchd[1]: Unknown key for boolean: NSSupportsSuddenTermination 2013-01-18 09:23:29 -0500 kernel[0]: Failed to load kext com.apple.driver.AppleSMCPDRC (error 0xdc00800e). 2013-01-18 09:23:29 -0500 kernel[0]: Kext com.apple.driver.AppleIntelHD3000Graphics – library kext com.apple.iokit.IOGraphicsFamily not found.Couldn’t alloc class “AppleSMCPDRC”
    2013-01-18 09:23:29 -0500 kernel[0]: Can’t load kext com.apple.driver.AppleIntelHD3000Graphics – failed to resolve library dependencies.
    2013-01-18 09:23:29 -0500 kernel[0]: Kext com.apple.driver.AppleIntelHD3000Graphics failed to load (0xdc00800e). 2013-01-18 09:23:29 -0500 kernel[0]: Failed to load kext com.apple.driver.AppleIntelHD3000Graphics (error 0xdc00800e).
    2013-01-18 09:23:29 -0500 kernel[0]: Couldn’t alloc class “Gen6Accelerator”
    2013-01-18 09:23:29 -0500 kernel[0]: RTC: Only single RAM bank (128 bytes)
    2013-01-18 09:23:29 -0500 kernel[0]: OSMetaClass: Kext org.netkas.driver.FakeSMC class FakeSMCKey is a duplicate;kext org.netkas.FakeSMC already has a class by that name.
    2013-01-18 09:23:29 -0500 kernel[0]: Kext org.netkas.driver.FakeSMC start failed (result 0xdc00400a).
    2013-01-18 09:23:29 -0500 kernel[0]: Kext org.netkas.driver.FakeSMC failed to load (0xdc008017).
    2013-01-18 09:23:29 -0500 kernel[0]: Failed to load kext org.netkas.driver.FakeSMC (error 0xdc008017). 2013-01-18 09:23:29 -0500 kernel[0]: mbinit: done [128 MB total pool size, (85/42) split]
    2013-01-18 09:23:29 -0500 kernel[0]: Pthread support ABORTS when sync kernel primitives misused
    2013-01-18 09:23:29 -0500 kernel[0]: Kext com.apple.driver.AppleHDAController – library kext com.apple.iokit.IOGraphicsFamily not found.
    2013-01-18 09:23:29 -0500 kernel[0]: Can’t load kext com.apple.driver.AppleHDAController – failed to resolve library dependencies.
    2013-01-18 09:23:29 -0500 kernel[0]: Kext com.apple.driver.AppleHDAController failed to load (0xdc00800e). 2013-01-18 09:23:29 -0500 kernel[0]: Failed to load kext com.apple.driver.AppleHDAController (error 0xdc00800e). 2013-01-18 09:23:29 -0500 kernel[0]: HDAEnabler: Copyright (c) 2008 by Kabyl
    2013-01-18 09:23:29 -0500 kernel[0]: HDAEnabler: 05/05/2008 Added SP-Audio support by Taruga
    2013-01-18 09:23:29 -0500 kernel[0]: HDAEnabler: 03/07/2009 Compiled for 32/64-bit by Taruga
    2013-01-18 09:23:29 -0500 kernel[0]: Couldn’t alloc class “AppleHDAController”
    2013-01-18 09:23:29 -0500 kernel[0]: rooting via boot-uuid from /chosen: F26F78D1-6515-3AC1-8C58- CE265AE14656
    2013-01-18 09:23:29 -0500 kernel[0]: Waiting on IOProviderClassIOResourcesIOResourceMatchboot-uuid-media 2013-01-18 09:23:29 -0500 kernel[0]: com.apple.AppleFSCompressionTypeDataless kmod start
    2013-01-18 09:23:29 -0500 kernel[0]: [RealtekRTL81xx:init] RealtekRTL81xx.kext v0.0.90 (c)2010-2011 by Lnx2Mac (lnx2mac@gmail.com)

  6. Everett says:

    Is it possible that you can zip up the kext files for the shuttle sh67h3 v1 and plac in dropbox?

    • cinlortech says:

      I no longer have a H3 V1 that’s running Mountain Lion. I didn’t back up the files either. I don’t think I even have an H3 with the V1 board in stock to reinstall ML.
      Maybe, one of our other readers running ML on the V1 can help you out.

  7. Adrian Jones says:

    Well strangely I built 2 hacks with GT 640, one on a Gigabyte H67 mb and he other with the shuttle. Identical graphics cards – one works with GraphicsEnabler=no the other with GraphicsEnabler=yes keyed in at the chameleon boot screen. Trial and error and then edited org.chameleon.Boot.plist in /Extra to reflect the different GraphicsEnabler strings and both work ok. Same version of Chameleon the lot. Weird – but it works OK so I am not going to worry too much.

    I thought I would get it booted with onboard graphics then get the GT640 working later – so I tried onboard graphics for ages and couldn’t understand why it wouldn’t work, then realised I had a Core i5 with no GPU – doh!

    A

  8. Adrian Jones says:

    “get stuck after loading com_lnx2mac_RealtekRTL81xx: Ethernet address xx:xx:xx:xx:xx:xx”

    I had that issue – when plugged into HDMI. Moved to DVI (didnt reboot) and the installer was running on the other screen.

    Problem I have now is after reboot – spinning ball on grey screen.

    Any ideas?

  9. gaetan29 says:

    Hi,
    I have followed your tutorial and managed to install and set up Mountain Lion on my SH67H3 Shuttle.
    But I can only boot Lion using the “-x” switch … If not, using the verbose mode, system get stuck after loading com_lnx2mac_RealtekRTL81xx: Ethernet address xx:xx:xx:xx:xx:xx

    Can someone suggest something ?

  10. Theodore Osborne says:

    Follow-up on my SH67H3 with V.2 Motherboard. Nothing I have tried will give me audio through HDMI. I cannot play back Youtube or movies using my LG Blu-Ray drive. iTunes video playback works but with no audio of course. It still resets the system clock and it will not shutdown, it only give that illusion. It just keeps rebooting. 😦
    They say you have to be patient when building a Hackintosh.

    • cinlortech says:

      Theodore – Which USB 3.0 driver are you using? Can you tell me what you checked off in MultiBeast and what version of MB?

      • Theodore Osborne says:

        Hi,
        I used Multibeast 1.5.3. I used the 3rd party option for USB 3.0 but it doesn’t work but it doesn’t work well in Windows 7 either. I don’t have and USB 3 stuff so the only thing I’m loosing is useful ports. USB 3 is supposed to be backward compatible but mine are glitchy at best.
        I installed a Radeon HD 5770 video card and switched to mac pro 3.1 as my Customizations /System Definitions, Video works slightly better but still no sound. It would be great if someone had really great detailed instructions on how to do this.

        Oh, and if you’re waiting for someone on one of these Hackintosh websites to get back to you about questions or problems you are having you might as well be waiting for Apple to get back to you!

      • cinlortech says:

        Theodore – Did you install the Asmedia USB 3.0 firmware update? I didn’t have a problem with the USB 3.0 in Windows 7. Here is the link to the update . See if this helps.

  11. Theodore Osborne says:

    I tried this with my version 2 MoBo but it did not work. I have everything working okay with some artifacts and no audio. YouTube video plays but only intermittently. This is progress.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

%d bloggers like this: